commons-httpclient:commons-httpclient (3.1)

Published 2026-08-11 20:08:58 +02:00 by jose.garcia

Installation

<repositories>
	<repository>
		<id>gitea</id>
		<url></url>
	</repository>
</repositories>

<distributionManagement>
	<repository>
		<id>gitea</id>
		<url></url>
	</repository>

	<snapshotRepository>
		<id>gitea</id>
		<url></url>
	</snapshotRepository>
</distributionManagement>
<dependency>
	<groupId>commons-httpclient</groupId>
	<artifactId>commons-httpclient</artifactId>
	<version>3.1</version>
</dependency>
mvn install
mvn dependency:get -DremoteRepositories= -Dartifact=commons-httpclient:commons-httpclient:3.1

About this package

The HttpClient component supports the client-side of RFC 1945 (HTTP/1.0) and RFC 2616 (HTTP/1.1) , several related specifications (RFC 2109 (Cookies) , RFC 2617 (HTTP Authentication) , etc.), and provides a framework by which new request types (methods) or HTTP extensions can be created easily.

Dependencies

junit:junit
3.8.1
commons-logging:commons-logging
1.0.4
commons-codec:commons-codec
1.2
Details
Maven
2026-08-11 20:08:58 +02:00
1
HttpClient
Apache License
305 KiB
Assets (2)
Versions (1) View all
3.1 2026-08-11